**[RESOLVED]** The newsletter delivery issues have been resolved.
**Current Status:** All delivery systems operational
Thank you for your patience while we worked to resolve this issue.
Posted Apr 06, 2026 - 09:25 UTC
Investigating
We are currently experiencing delays with newsletter delivery. Our team has been notified and is actively working to resolve the issue.
**Current Status:** Investigating
**What we're doing:** - Our engineering team is working to identify and resolve the delivery bottleneck - We are monitoring email delivery queues closely - We will provide updates as the situation improves
**Expected Impact:** Some newsletters may be delivered later than scheduled. All newsletters will be delivered, but there may be delays. We apologize for any inconvenience this may cause.
We will post updates here as we resolve the delivery delays. Thank you for your patience.